New account registration service temporarily suspended

Incident Report for DeepForth AI

Update

We are continuing to work on a fix for this issue.
Posted Feb 04, 2025 - 06:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 04, 2025 - 06:11 UTC
This incident affects: Website.